Update problems in Hardy

I know this will get to a lot of the old pro’s, but I am new and the CLI is still something I need to learn about. With that in mind, when my package manager reports there are updates, I can see them and click on “Install updates”, the problem comes just after that. And the following is given as an output:

W: Failed to fetch http://ftp.leg.uct.ac.za/pub/linux/ubuntu/pool/main/s/samba/winbind_3.0.28a-1ubuntu4.4_amd64.deb Could not resolve ‘http’

W: Failed to fetch http://ftp.leg.uct.ac.za/pub/linux/ubuntu/pool/universe/w/wine/wine_1.0.0-1ubuntu4~hardy1_amd64.deb Could not resolve ‘http’

W: Failed to fetch http://ftp.leg.uct.ac.za/pub/linux/ubuntu/pool/main/g/gtk2-engines-murrine/gtk2-engines-murrine_0.53.1-1ubuntu2_amd64.deb Could not resolve ‘http’

W: Failed to fetch http://ftp.leg.uct.ac.za/pub/linux/ubuntu/pool/main/u/ubuntulooks/gtk2-engines-ubuntulooks_0.9.12-12_amd64.deb Could not resolve ‘http’

W: Failed to fetch http://ftp.leg.uct.ac.za/pub/linux/ubuntu/pool/main/p/poppler/libpoppler2_0.6.4-1ubuntu3_amd64.deb Could not resolve ‘http’

W: Failed to fetch http://ftp.leg.uct.ac.za/pub/linux/ubuntu/pool/main/p/poppler/libpoppler-glib2_0.6.4-1ubuntu3_amd64.deb Could not resolve ‘http’

W: Failed to fetch http://ftp.leg.uct.ac.za/pub/linux/ubuntu/pool/restricted/l/linux-restricted-modules-2.6.24/linux-restricted-modules-common_2.6.24.13-19.45_all.deb Could not resolve ‘http’

W: Failed to fetch http://ftp.leg.uct.ac.za/pub/linux/ubuntu/pool/restricted/l/linux-restricted-modules-2.6.24/linux-restricted-modules-2.6.24-19-generic_2.6.24.13-19.45_amd64.deb Could not resolve ‘http’

W: Failed to fetch http://ftp.leg.uct.ac.za/pub/linux/ubuntu/pool/restricted/l/linux-restricted-modules-2.6.24/nvidia-glx-new_169.12+2.6.24.13-19.45_amd64.deb Could not resolve ‘http’

W: Failed to fetch http://ftp.leg.uct.ac.za/pub/linux/ubuntu/pool/main/p/poppler/poppler-utils_0.6.4-1ubuntu3_amd64.deb Could not resolve ‘http’

W: Failed to fetch http://ftp.leg.uct.ac.za/pub/linux/ubuntu/pool/multiverse/u/ubuntu-restricted-extras/ubuntu-restricted-extras_15.2_amd64.deb Could not resolve ‘http’

Is this a problem with my sources list? If so how can I fix it… Or is it a problem with the server? any help would be greatly appreciated

That screams sources.list

It looks like a bad sources.list, yes.

Use the version on: this page

Still confused...

Hi Stefanor,

I tried to edit my sources list - I am a newbie to CLI but used a terminal in “super user mode” and entered “vim /etc/apt/sources.list” which gave me

deb http://ftp.leg.uct.ac.za/pub/linux/ubuntu/ hardy main universe multiverse restricted

deb http://ftp.leg.uct.ac.za/pub/linux/ubuntu/ hardy-updates main universe multiverse restricted

deb http://ftp.leg.uct.ac.za/pub/linux/ubuntu/ hardy-security main universe multiverse restricted

# deb http://ftp.leg.uct.ac.za/pub/linux/medibuntu/ hardy free non-free

as far as I can tell this is what the sources lists should look like according to the link you posted previously. How can I become a “super user” without logging into a superuser terminal? I am just a bit cautious about maybe making mistakes as a super user so would only want to execute those commands at specific times.

I am pretty sure my sources list hasn’t been altered for the since I upgraded to Hardy could it really be a bad sources list if this is the first time I have been unable to update?

Re: Still confused...

Sorry I didn’t pick this up sooner. It was flagged as spam :-(

Oh, and you’ll generally get faster help on the mailing list than here, because I seem to be the only person who reads the forum ;-)

How can I become a “super user” without logging into a superuser terminal?

You can either execute a command with sudo in front of it (i.e. sudo aptitude update) or enter a root shell with:

$ sudo -i

As to why you are still getting that error - I don’t know.

Proxy server settings

When you were prompted for a proxy during the initail setup, did you put http://proxyservername or the server name. I put http://proxyservername and got this same error. To resolve this;

1.I went into Firefox and changed to use the system proxy.
2.So to system/preferences/network proxy, choose Direct Internet connection, then select “Apply System Wide”. You should be promted twice for a password.
3. then select Manual proxy configuration and just enter the server name. Then select “Apply System Wide”.

This may be a bit overkill, but it solved my issue.

Syndicate content