ISA proxies on campus problem

Hello
I’m trying to get cntlm to work with the proxies on campus. Running Ubuntu Intrepid. I’ve followed the LEG howto re cntlm, installed cntlm and changed the config file, and updated the system wide http proxy using gnome to localhost. Didn’t bother with the transparent method. When I try running wget then I get the following error:

jem@jem:~$ sudo wget http://www.medibuntu.org/sources.list.d/intrepid.list —output-document=/etc/apt/sources.list.d/medibuntu.list
—2009-02-06 14:17:36— http://www.medibuntu.org/sources.list.d/intrepid.list
Resolving localhost… 127.0.0.1
Connecting to localhost|127.0.0.1|:8080… connected.
Proxy request sent, awaiting response… 407 Proxy Authentication Required ( The ISA Server requires authorization to fulfill the request. Access to the Web Proxy filter is denied. )
2009-02-06 14:17:36 ERROR 407: Proxy Authentication Required ( The ISA Server requires authorization to fulfill the request. Access to the Web Proxy filter is denied. )

The contents of my /etc/cntlm.conf file are as follows:

Username sprjer002
Domain wf
Password XXXXXXXXX
Proxy campusnet.uct.ac.za:8080
Listen 8080

The username and password are both correct.
When I try running cntlm on its own I get this:

jem@jem:~$ sudo cntlm -v
Default config file opened successfully
cntlm: Cannot bind port 8080: Address already in use!
cntlm: Resolving proxy campusnet.uct.ac.za…
cntlm: No proxy service ports were successfully opened.
Exitting with error. Check daemon logs or run with -v.

Any assistance in getting cntlm to work with wget would be much appreciated. Thanks in advance.

Re: Cannot bind port 8080

Looks like your cntlm is already running (started at bootup, presuably). Stop it with:

$ sudo invoke-rc.d cntlm stop

Thanks stefanor,

Thanks stefanor, this worked!

Connecting To Campus Net(Ubuntu 9.10)

Hi everyone

I’ve been using Ubuntu for two years, so I’m no expect, but an enthusiast only. Proxies present a great security for the University, but that comes with great complexity for those of us who are nobs. Recently i tried to connect to UCT campus net, but couldn’t, there’s only a manuals for Windows and Mac users and that is unfair, but i was able to go around that and connect anyway. Ubuntu 9.10 does everything for you all you need is the certificate! I downloaded the Thwate Premium Server CA.pem and when you are in range a dialog will pop up asking for the credentials, all you need do there is change the Authentication to Protected EAP, select the certificate where ever it is and make sure the Inner Authentication is set to MSCHAPv2 and PEAP is on Version 2 and the rest is your student number and password!

Also, I was experiencing problems with downloading adobe flash player due to the ttf-mscorefonts-installer, the most annoying installer from microsoft. I just went to the Synaptic Package Manager and removed(completely), no harm was done to the system, i was able to download!

Syndicate content