Debian & Ubuntu sources

Added sources for the Debian and Ubuntu repositories this weekend. This means that deb-src lines in /etc/apt/sources.list won’t produce errors.

Also added canonical-partner, together with a virtualhost, so if you run

$ http_proxy=http://ftp.leg.uct.ac.za:80/ sudo aptitude install flashplugin-installer

It should download and install flash correctly.

Comments

Sudo in the wrong place

Sudo in the wrong place there, should be:

$ sudo http_proxy=http://ftp.leg.uct.ac.za:80/ aptitude install flashplugin-installer

Flash plugin upgrades

I tried the command

$ sudo http_proxy=http://ftp.leg.uct.ac.za:80/ aptitude install flashplugin-installer
and it used to work but now it doesn’t work any more. Whenever I try to install/upgrade Flash, it doesn’t work and I get this response:
The following partially installed packages will be configured:
  flashplugin-installer 
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.
Setting up flashplugin-installer (10.3.183.7ubuntu0.11.04.1) ...
Downloading...
--2011-08-29 16:56:30--  <a href="http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_10.3.183.7.orig.tar.gz<br />
Resolving" title="http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_10.3.183.7.orig.tar.gz<br />
Resolving">http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flas...</a> campusnet.uct.ac.za... 137.158.153.185
Connecting to campusnet.uct.ac.za|137.158.153.185|:8080... connected.
Proxy request sent, awaiting response... 407 Proxy Authentication Required ( Forefront TMG requires authorization to fulfill the request. Access to the Web Proxy filter is denied.  )
2011-08-29 16:56:31 ERROR 407: Proxy Authentication Required ( Forefront TMG requires authorization to fulfill the request. Access to the Web Proxy filter is denied.  ).
 
download failed
The Flash plugin is NOT installed.

My CNTLM is up to date and properly installed, so is this another ICTS problem?

System wide proxy settings

Unset your “system wide” proxy settings

Syndicate content